re = /(^|\/)\.(?!(specific_allowed_file|specific_allowed_folder)(\/|$))/m
str = 'https://example.com/.forbidden_file
https://example.com/.forbidden_folder/somefile.txt
https://example.com/.specific_allowed_file
https://example.com/.specific_allowed_folder/somefile.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end