$re = '@(^|/)\.(?!(specific_allowed_file|specific_allowed_folder)(/|$))@m';
$str = 'https://example.com/.forbidden_file
https://example.com/.forbidden_folder/somefile.txt
https://example.com/.specific_allowed_file
https://example.com/.specific_allowed_folder/somefile.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);