const regex = new RegExp('(^|/)\\.(?!(specific_allowed_file|specific_allowed_folder)(/|$))', 'gm')
const str = `https://example.com/.forbidden_file
https://example.com/.forbidden_folder/somefile.txt
https://example.com/.specific_allowed_file
https://example.com/.specific_allowed_folder/somefile.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}