#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=family\:\s)[\s\S]*?(?=[;\s])"
Local $sString = "<span style="font-family: TimesNewRoman; font-size: 12"><p>My text<br /><br />" & @CRLF & _
"<span style="font-family: 'Georgia','serif'; color: #1a1a1a;">Description is here</span> Detail description</strong></p>" & @CRLF & _
"</span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")