use strict;
my $str = '<span style="font-family: TimesNewRoman; font-size: 12"><p>My text<br /><br />
<span style="font-family: \'Georgia\',\'serif\'; color: #1a1a1a;">Description is here</span> Detail description</strong></p>
</span>';
my $regex = qr/(?<=family\:\s)[\s\S]*?(?=[;\s])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}