$re = '/(?<=family\:\s)[\s\S]*?(?=[;\s])/';
$str = '<span style="font-family: TimesNewRoman; font-size: 12"><p>My text<br /><br />
<span style="font-family: \'Georgia\',\'serif\'; color: #1a1a1a;">Description is here</span> Detail description</strong></p>
</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);