import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=family\\:\\s)[\\s\\S]*?(?=[;\\s])";
final String string = "<span style=\"font-family: TimesNewRoman; font-size: 12\"><p>My text<br /><br />\n"
+ "<span style=\"font-family: 'Georgia','serif'; color: #1a1a1a;\">Description is here</span> Detail description</strong></p>\n"
+ "</span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}