using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:ABC=(?<abc>\d+)&&DEF=(?<def>\d+))+";
string input = @"description=beg Area1 - ABC=704&&DEF=03||ABC=706&&DEF=04
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}