// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:ABC=(?<abc>\d+)&&DEF=(?<def>\d+))+").unwrap();
let string = "description=beg Area1 - ABC=704&&DEF=03||ABC=706&&DEF=04
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}