const regex = new RegExp('(?:ABC=(?<abc>\\d+)&&DEF=(?<def>\\d+))+', 'gm')
const str = `description=beg Area1 - ABC=704&&DEF=03||ABC=706&&DEF=04
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}