# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<!--.*?-->//gms;t' <<< "<p>teste<p>
<!-- <!-- comentário mal formado ->---"