re = /<!--.*?-->/m
str = '<p>teste<p>
<!-- <!-- comentário mal formado ->---'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result