const regex = /<!--.*?-->/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!--.*?-->', 'gms')
const str = `<p>teste<p>
<!-- <!-- comentário mal formado ->---`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);