$re = '/<!--.*?-->/ms';
$str = '<p>teste<p>
<!-- <!-- comentário mal formado ->---';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;