import re
regex = re.compile(r"<!--.*?-->", flags=re.MULTILINE | re.DOTALL)
test_str = ("<p>teste<p>\n"
"<!-- <!-- comentário mal formado ->---")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)