using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"var (.*?) = 3";
string input = @"var abc1 = 1; var abc2 = 2; var abc3 = 3; var abc4 = 4;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}