const regex = /var (.*?) = 3/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('var (.*?) = 3', 'g')
const str = `var abc1 = 1; var abc2 = 2; var abc3 = 3; var abc4 = 4;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}