// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"var (.*?) = 3").unwrap();
let string = "var abc1 = 1; var abc2 = 2; var abc3 = 3; var abc4 = 4;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}