package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`var (.*?) = 3`)
var str = `var abc1 = 1; var abc2 = 2; var abc3 = 3; var abc4 = 4;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}