$re = '/var (.*?) = 3/';
$str = 'var abc1 = 1; var abc2 = 2; var abc3 = 3; var abc4 = 4;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);