using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w+(\s+\w+)*),\s?(\d+)\s+-\s+([\w-\s:]+(\s+\w+)*-?[\w+\s+:;]),\s?(\w+(\s+\w+)*)\s?-?\s?(\w+(\s+\w+)*),\s?(\w{2,})$";
string input = @"R dos Guajajaras, 1333 - lj-27, Barro Preto - Belo Horizonte, MG";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}