import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+(\\s+\\w+)*),\\s?(\\d+)\\s+-\\s+([\\w-\\s:]+(\\s+\\w+)*-?[\\w+\\s+:;]),\\s?(\\w+(\\s+\\w+)*)\\s?-?\\s?(\\w+(\\s+\\w+)*),\\s?(\\w{2,})$";
final String string = "R dos Guajajaras, 1333 - lj-27, Barro Preto - Belo Horizonte, MG";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}