const regex = /^(\w+(\s+\w+)*),\s?(\d+)\s+-\s+([\w-\s:]+(\s+\w+)*-?[\w+\s+:;]),\s?(\w+(\s+\w+)*)\s?-?\s?(\w+(\s+\w+)*),\s?(\w{2,})$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+(\\s+\\w+)*),\\s?(\\d+)\\s+-\\s+([\\w-\\s:]+(\\s+\\w+)*-?[\\w+\\s+:;]),\\s?(\\w+(\\s+\\w+)*)\\s?-?\\s?(\\w+(\\s+\\w+)*),\\s?(\\w{2,})$', 'g')
const str = `R dos Guajajaras, 1333 - lj-27, Barro Preto - Belo Horizonte, MG`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}