package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\w+(\s+\w+)*),\s?(\d+)\s+-\s+([\w-\s:]+(\s+\w+)*-?[\w+\s+:;]),\s?(\w+(\s+\w+)*)\s?-?\s?(\w+(\s+\w+)*),\s?(\w{2,})$`)
var str = `R dos Guajajaras, 1333 - lj-27, Barro Preto - Belo Horizonte, MG`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}