using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\w)\w+[^,]+ (\w+)";
string substitution = @"$1$2@gmail.com";
string input = @"John H. Kirk, Fred Andrew Polk, William Mills";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}