import re
regex = re.compile(r"\b(\w)\w+[^,]+ (\w+)", flags=re.MULTILINE)
test_str = "John H. Kirk, Fred Andrew Polk, William Mills"
subst = "$1$2@gmail.com"
result = regex.sub(subst, test_str)
if result:
print(result)