const regex = /\b(\w)\w+[^,]+ (\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\w)\\w+[^,]+ (\\w+)', 'gm')
const str = `John H. Kirk, Fred Andrew Polk, William Mills`;
const subst = `$1$2@gmail.com`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);