$re = '/\b(\w)\w+[^,]+ (\w+)/m';
$str = 'John H. Kirk, Fred Andrew Polk, William Mills';
$subst = "$1$2@gmail.com";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;