// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(\w)\w+[^,]+ (\w+)").unwrap();
let string = "John H. Kirk, Fred Andrew Polk, William Mills";
let substitution = "$1$2@gmail.com";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}