package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+(?: \d+)*(?:,\d+)?`)
var str = `Объем куб.м. — 0,448
Длина (мм.) — 1 880 мм.
Ширина (мм.) — 1 490 мм.
Высота (мм.) — 160 мм.
Масса (кг.) — 630 кг.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}