import Foundation
let pattern = #"\d+(?: \d+)*(?:,\d+)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Объем куб.м. — 0,448
Длина (мм.) — 1 880 мм.
Ширина (мм.) — 1 490 мм.
Высота (мм.) — 160 мм.
Масса (кг.) — 630 кг.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)