re = /\d+(?: \d+)*(?:,\d+)?/
str = 'Объем куб.м. — 0,448
Длина (мм.) — 1 880 мм.
Ширина (мм.) — 1 490 мм.
Высота (мм.) — 160 мм.
Масса (кг.) — 630 кг.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end