// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d+(?: \d+)*(?:,\d+)?").unwrap();
let string = "Объем куб.м. — 0,448
Длина (мм.) — 1 880 мм.
Шири на (мм.) — 1 490 мм.
Высота (мм.) — 160 мм.
Масса (кг.) — 630 кг.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}