using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https?://)?(www\.)?youtu(\.be|be\.com)/(watch\?v=|embed/)?(?<id>[\w-]{11,})";
string input = @"https://youtube.com/watch?v=q9s_9RZ6lvw
https://www.youtube.com/watch?v=q9s_9RZ6lvw
https://youtu.be/q9s_9RZ6lvw
https://www.youtube.com/embed/q9s_9RZ6lvw
https://youtube.com/embed/q9s_9RZ6lvw
youtube.com/watch?v=q9s_9RZ6lvw
www.youtube.com/watch?v=q9s_9RZ6lvw
youtu.be/q9s_9RZ6lvw
youtube.com/embed/q9s_9RZ6lvw
http://youtube.com/watch?v=q9s_9RZ6lvw
http://www.youtube.com/watch?v=q9s_9RZ6lvw
http://youtu.be/q9s_9RZ6lvw
http://www.youtube.com/embed/q9s_9RZ6lvw
http://youtube.com/embed/q9s_9RZ6lvw
http://youtube.com/watch?v=q9s_9RZ6lvw&rel=1
http://www.youtube.com/watch?v=q9s_9RZ6lvw&autoplay=1
http://youtu.be/q9s_9RZ6lvw?ref=0
http://www.youtube.com/embed/q9s_9RZ6lvw?abc=xyz
http://youtube.com/embed/q9s_9RZ6lvw?1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}