import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?://)?(www\\.)?youtu(\\.be|be\\.com)/(watch\\?v=|embed/)?(?<id>[\\w-]{11,})";
final String string = "https://youtube.com/watch?v=q9s_9RZ6lvw\n"
+ "https://www.youtube.com/watch?v=q9s_9RZ6lvw\n"
+ "https://youtu.be/q9s_9RZ6lvw\n"
+ "https://www.youtube.com/embed/q9s_9RZ6lvw\n"
+ "https://youtube.com/embed/q9s_9RZ6lvw\n"
+ "youtube.com/watch?v=q9s_9RZ6lvw\n"
+ "www.youtube.com/watch?v=q9s_9RZ6lvw\n"
+ "youtu.be/q9s_9RZ6lvw\n"
+ "youtube.com/embed/q9s_9RZ6lvw\n"
+ "http://youtube.com/watch?v=q9s_9RZ6lvw\n"
+ "http://www.youtube.com/watch?v=q9s_9RZ6lvw\n"
+ "http://youtu.be/q9s_9RZ6lvw\n"
+ "http://www.youtube.com/embed/q9s_9RZ6lvw\n"
+ "http://youtube.com/embed/q9s_9RZ6lvw\n"
+ "http://youtube.com/watch?v=q9s_9RZ6lvw&rel=1\n"
+ "http://www.youtube.com/watch?v=q9s_9RZ6lvw&autoplay=1\n"
+ "http://youtu.be/q9s_9RZ6lvw?ref=0\n"
+ "http://www.youtube.com/embed/q9s_9RZ6lvw?abc=xyz\n"
+ "http://youtube.com/embed/q9s_9RZ6lvw?1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}