re = /^(https?:\/\/)?(www\.)?youtu(\.be|be\.com)\/(watch\?v=|embed\/)?(?<id>[\w-]{11,})/m
str = 'https://youtube.com/watch?v=q9s_9RZ6lvw
https://www.youtube.com/watch?v=q9s_9RZ6lvw
https://youtu.be/q9s_9RZ6lvw
https://www.youtube.com/embed/q9s_9RZ6lvw
https://youtube.com/embed/q9s_9RZ6lvw
youtube.com/watch?v=q9s_9RZ6lvw
www.youtube.com/watch?v=q9s_9RZ6lvw
youtu.be/q9s_9RZ6lvw
youtube.com/embed/q9s_9RZ6lvw
http://youtube.com/watch?v=q9s_9RZ6lvw
http://www.youtube.com/watch?v=q9s_9RZ6lvw
http://youtu.be/q9s_9RZ6lvw
http://www.youtube.com/embed/q9s_9RZ6lvw
http://youtube.com/embed/q9s_9RZ6lvw
http://youtube.com/watch?v=q9s_9RZ6lvw&rel=1
http://www.youtube.com/watch?v=q9s_9RZ6lvw&autoplay=1
http://youtu.be/q9s_9RZ6lvw?ref=0
http://www.youtube.com/embed/q9s_9RZ6lvw?abc=xyz
http://youtube.com/embed/q9s_9RZ6lvw?1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end