re = /^Exactfoobar(?:\.[a-z0-9][a-z0-9_-]*){2}(?:\.[a-zA-Z0-9][a-zA-Z0-9_-]*)+$/m
str = 'Exactfoobar.somestring.some_other-string.someStringwithCaps
There could be 4 or more fields separated by a dot
The first word should be exactly Exactfoobar.
The 2nd and 3rd word can\'t have caps but can have -_
The 4th word and so on can have caps with -_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end