#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+(\s?[a-zA-Z]?\s?|\s?[a-zA-Z]$))"
Local $sString = "My house number is 23" & @CRLF & _
"23" & @CRLF & _
"23a" & @CRLF & _
"23 a" & @CRLF & _
"The house number is 23 a and the street ist XY" & @CRLF & _
"The house number is 23 a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")