// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+(\s?[a-zA-Z]?\s?|\s?[a-zA-Z]$))").unwrap();
let string = "My house number is 23
23
23a
23 a
The house number is 23 a and the street ist XY
The house number is 23 a";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}