using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+(\s?[a-zA-Z]?\s?|\s?[a-zA-Z]$))";
string input = @"My house number is 23
23
23a
23 a
The house number is 23 a and the street ist XY
The house number is 23 a";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}