$re = '/(\d+(\s?[a-zA-Z]?\s?|\s?[a-zA-Z]$))/m';
$str = 'My house number is 23
23
23a
23 a
The house number is 23 a and the street ist XY
The house number is 23 a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);