package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+(\s?[a-zA-Z]?\s?|\s?[a-zA-Z]$))`)
var str = `My house number is 23
23
23a
23 a
The house number is 23 a and the street ist XY
The house number is 23 a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}