import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:(?:.*\\.)?windowsupdate|(?:.*\\.)?update|download|ntservicepack|go|(?:.|dl)+\\.delivery\\.mp)\\.microsoft|(?:.|download\\.)+windowsupdate|wustat\\.windows)\\.com$";
final String string = "windowsupdate.microsoft.com\n"
+ "wildcard.windowsupdate.microsoft.com\n"
+ "wildcard.update.microsoft.com\n"
+ "download.microsoft.com\n"
+ "ntservicepack.microsoft.com\n"
+ "go.microsoft.com\n"
+ "dl.delivery.mp.microsoft.com\n"
+ "dl.delivery.mp.microsoft.com\n"
+ "wildcard.delivery.mp.microsoft.com\n"
+ "wildcard.delivery.mp.microsoft.com\n\n"
+ "wildcard.windowsupdate.com\n"
+ "download.windowsupdate.com\n"
+ "wildcard.download.windowsupdate.com\n\n"
+ "wustat.windows.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}