import Foundation
let pattern = #"^(?:(?:(?:.*\.)?windowsupdate|(?:.*\.)?update|download|ntservicepack|go|(?:.|dl)+\.delivery\.mp)\.microsoft|(?:.|download\.)+windowsupdate|wustat\.windows)\.com$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
windowsupdate.microsoft.com
wildcard.windowsupdate.microsoft.com
wildcard.update.microsoft.com
download.microsoft.com
ntservicepack.microsoft.com
go.microsoft.com
dl.delivery.mp.microsoft.com
dl.delivery.mp.microsoft.com
wildcard.delivery.mp.microsoft.com
wildcard.delivery.mp.microsoft.com
wildcard.windowsupdate.com
download.windowsupdate.com
wildcard.download.windowsupdate.com
wustat.windows.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)