re = /^(?:(?:(?:.*\.)?windowsupdate|(?:.*\.)?update|download|ntservicepack|go|(?:.|dl)+\.delivery\.mp)\.microsoft|(?:.|download\.)+windowsupdate|wustat\.windows)\.com$/mi
str = 'windowsupdate.microsoft.com
wildcard.windowsupdate.microsoft.com
wildcard.update.microsoft.com
download.microsoft.com
ntservicepack.microsoft.com
go.microsoft.com
dl.delivery.mp.microsoft.com
dl.delivery.mp.microsoft.com
wildcard.delivery.mp.microsoft.com
wildcard.delivery.mp.microsoft.com
wildcard.windowsupdate.com
download.windowsupdate.com
wildcard.download.windowsupdate.com
wustat.windows.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end