// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:(?:(?:.*\.)?windowsupdate|(?:.*\.)?update|download|ntservicepack|go|(?:.|dl)+\.delivery\.mp)\.microsoft|(?:.|download\.)+windowsupdate|wustat\.windows)\.com$").unwrap();
let string = "windowsupdate.microsoft.com
wildcard.windowsupdate.microsoft.com
wildcard.update.microsoft.com
download.microsoft.com
ntservicepack.microsoft.com
go.microsoft.com
dl.delivery.mp.microsoft.com
dl.delivery.mp.microsoft.com
wildcard.delivery.mp.microsoft.com
wildcard.delivery.mp.microsoft.com
wildcard.windowsupdate.com
download.windowsupdate.com
wildcard.download.windowsupdate.com
wustat.windows.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}