use strict;
my $str = 'windowsupdate.microsoft.com
wildcard.windowsupdate.microsoft.com
wildcard.update.microsoft.com
download.microsoft.com
ntservicepack.microsoft.com
go.microsoft.com
dl.delivery.mp.microsoft.com
dl.delivery.mp.microsoft.com
wildcard.delivery.mp.microsoft.com
wildcard.delivery.mp.microsoft.com
wildcard.windowsupdate.com
download.windowsupdate.com
wildcard.download.windowsupdate.com
wustat.windows.com';
my $regex = qr/^(?:(?:(?:.*\.)?windowsupdate|(?:.*\.)?update|download|ntservicepack|go|(?:.|dl)+\.delivery\.mp)\.microsoft|(?:.|download\.)+windowsupdate|wustat\.windows)\.com$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}