#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:[0-9]|1[0-9]|2[0-4])(?:\.[0-9])?|25(?:\.)?)$"
Local $sString = "2" & @CRLF & _
"2.5" & @CRLF & _
"23.0" & @CRLF & _
"8" & @CRLF & _
"24.3" & @CRLF & _
"25" & @CRLF & _
"25.0" & @CRLF & _
"0.01" & @CRLF & _
"-1" & @CRLF & _
"25.00" & @CRLF & _
"26"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")