package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:[0-9]|1[0-9]|2[0-4])(?:\.[0-9])?|25(?:\.)?)$`)
var str = `2
2.5
23.0
8
24.3
25
25.0
0.01
-1
25.00
26`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}