using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:[0-9]|1[0-9]|2[0-4])(?:\.[0-9])?|25(?:\.)?)$";
string input = @"2
2.5
23.0
8
24.3
25
25.0
0.01
-1
25.00
26";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}